Dec 052014
 

The Dell model Precision M3800 has a SSD disk configured as a second harddisk, disk 1. Disk 0 is a magnetic drive.

Problem in SCCM2012 is that I was unabel to find a fast solution for the fact that partitioning didn`t went well in the task sequence. I got different results with different configurations but no disk 0 with a driver letter D and a disk 1 with a drive letter C.

I wrote this diskpart script to partition the drive en format the Dell Precision M3800. It will format both drivers, only for first install`s.

rem ++++ change the bootmedia driver letter
select vol c
assign letter=g
select vol d
assign letter=h
rem ++++ Format SSD drive 1
select disk 1
clean
convert gpt
rem ++ Par 1
create partition primary size=300
format quick fs=ntfs label="Windows RE tools"
set id="de94bba4-06d1-4d40-a16a-bfd50179d6ac"
gpt attributes=0x8000000000000001
rem ++ Par 2
create partition efi size=100
format quick fs=fat32 label="System"
rem ++ Par 3
create partition msr size=128
rem ++ Par 4
create partition primary 
format quick fs=ntfs label="Windows"
assign letter="C"
rem ++++ Format Magnetic drive 0
select disk 0
clean
create partition primary 
format quick fs=ntfs label="Storage"
assign letter="D"
exit

Create a package with the txt file and run it with diskpart.

Screen 05-dec 0005

The USB ethernet USB-dongle delivered with the notebook should be able to work with PXE. Non the less I wass able to boot only once in 20 try`s in different setups from PXE in UEFI mode.
It does work better in legacy BIOS mode, but in UEFI mode it doesn`t.
More info at this post from John Willes; Dell XPS 15, PXE booting over USB NIC

 

 Leave a Reply

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

(required)

(required)